#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\b(Quarantine|Inspection)_Bin)\([0-9]+\)"
Local $sString = "Quarantine(2),Other_Bin(2),Quarantine_Bin(2),Quarantine_Bin(2)," & @CRLF & _
"Quarantine_Bin(5),Inspection_Bin(3),Regular_Bin(5),other(2)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")