const regex = /(?<!\b(Quarantine|Inspection)_Bin)\([0-9]+\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\b(Quarantine|Inspection)_Bin)\\([0-9]+\\)', 'g')
const str = `Quarantine(2),Other_Bin(2),Quarantine_Bin(2),Quarantine_Bin(2),
Quarantine_Bin(5),Inspection_Bin(3),Regular_Bin(5),other(2)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}