import re
regex = re.compile(r"(?<!\b(Quarantine|Inspection)_Bin)\([0-9]+\)")
test_str = ("Quarantine(2),Other_Bin(2),Quarantine_Bin(2),Quarantine_Bin(2),\n"
"Quarantine_Bin(5),Inspection_Bin(3),Regular_Bin(5),other(2)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")