re = /(?<!\b(Quarantine|Inspection)_Bin)\([0-9]+\)/
str = 'Quarantine(2),Other_Bin(2),Quarantine_Bin(2),Quarantine_Bin(2),
Quarantine_Bin(5),Inspection_Bin(3),Regular_Bin(5),other(2)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end