import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\b(Quarantine|Inspection)_Bin)\\([0-9]+\\)";
final String string = "Quarantine(2),Other_Bin(2),Quarantine_Bin(2),Quarantine_Bin(2),\n"
+ "Quarantine_Bin(5),Inspection_Bin(3),Regular_Bin(5),other(2)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}