#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)entry \d+: (?:(?!entry \d+: ).)*special.*?(?=\s*entry \d+: |$)"
Local $sString = "entry 1: hello" & @CRLF & _
"entry 2: world" & @CRLF & _
"entry 3: this" & @CRLF & _
"is a multiline" & @CRLF & _
"that makes it hard" & @CRLF & _
"entry 4: here we have a special entry" & @CRLF & _
"entry 5: here" & @CRLF & _
"we" & @CRLF & _
"have " & @CRLF & _
"another special entry" & @CRLF & _
"in a multiline" & @CRLF & _
"entry 6: end"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")