using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"entry \d+: (?:(?!entry \d+: ).)*special.*?(?=\s*entry \d+: |$)";
string input = @"entry 1: hello
entry 2: world
entry 3: this
is a multiline
that makes it hard
entry 4: here we have a special entry
entry 5: here
we
have
another special entry
in a multiline
entry 6: end";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}