re = /entry \d+: (?:(?!entry \d+: ).)*special.*?(?=\s*entry \d+: |$)/
str = 'entry 1: hello
entry 2: world
entry 3: this
is a multiline
that makes it hard
entry 4: here we have a special entry
entry 5: here
we
have
another special entry
in a multiline
entry 6: end'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end