import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "entry \\d+: (?:(?!entry \\d+: ).)*special.*?(?=\\s*entry \\d+: |$)";
final String string = "entry 1: hello\n"
+ "entry 2: world\n"
+ "entry 3: this\n"
+ "is a multiline\n"
+ "that makes it hard\n"
+ "entry 4: here we have a special entry\n"
+ "entry 5: here\n"
+ "we\n"
+ "have \n"
+ "another special entry\n"
+ "in a multiline\n"
+ "entry 6: end";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}