#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Blok\s(.*)(\sNo)|No\.(.*)(\,|\s)"
Local $sString = "Jl. Gotong Royong 1 No.3A, Kapuk, Cengkareng" & @CRLF & _
"Jl. Gotong Royong 1 No.3A Kapuk, Cengkareng" & @CRLF & _
"Jl. Gotong Royong 1 No.3A" & @CRLF & _
"Jl. Gotong Royong 1 Blok M No.3A, Kapuk, Cengkareng" & @CRLF & _
"Jl. Gotong Royong 1 Blok M-1 No.3A, Kapuk, Cengkareng" & @CRLF & _
"Jl. Gotong Royong 1 Blok 3A, Kapuk, Cengkareng" & @CRLF & _
"Jl. Gotong Royong 1 Blok 3A Kapuk, Cengkareng" & @CRLF & _
"Jl. Gotong Royong 1 Blok 3A" & @CRLF & _
"G-Land Padalarang Residence Blok C No.1, Jayamekar, Padalarang" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")