import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Blok\\s(.*)(\\sNo)|No\\.(.*)(\\,|\\s)";
final String string = "Jl. Gotong Royong 1 No.3A, Kapuk, Cengkareng\n"
+ "Jl. Gotong Royong 1 No.3A Kapuk, Cengkareng\n"
+ "Jl. Gotong Royong 1 No.3A\n"
+ "Jl. Gotong Royong 1 Blok M No.3A, Kapuk, Cengkareng\n"
+ "Jl. Gotong Royong 1 Blok M-1 No.3A, Kapuk, Cengkareng\n"
+ "Jl. Gotong Royong 1 Blok 3A, Kapuk, Cengkareng\n"
+ "Jl. Gotong Royong 1 Blok 3A Kapuk, Cengkareng\n"
+ "Jl. Gotong Royong 1 Blok 3A\n"
+ "G-Land Padalarang Residence Blok C No.1, Jayamekar, Padalarang\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}