$re = '/Blok\s(.*)(\sNo)|No\.(.*)(\,|\s)/m';
$str = 'Jl. Gotong Royong 1 No.3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 No.3A Kapuk, Cengkareng
Jl. Gotong Royong 1 No.3A
Jl. Gotong Royong 1 Blok M No.3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok M-1 No.3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok 3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok 3A Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok 3A
G-Land Padalarang Residence Blok C No.1, Jayamekar, Padalarang
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);