use strict;
my $str = 'Jl. Gotong Royong 1 No.3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 No.3A Kapuk, Cengkareng
Jl. Gotong Royong 1 No.3A
Jl. Gotong Royong 1 Blok M No.3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok M-1 No.3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok 3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok 3A Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok 3A
G-Land Padalarang Residence Blok C No.1, Jayamekar, Padalarang
';
my $regex = qr/Blok\s(.*)(\sNo)|No\.(.*)(\,|\s)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}