package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Blok\s(.*)(\sNo)|No\.(.*)(\,|\s)`)
var str = `Jl. Gotong Royong 1 No.3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 No.3A Kapuk, Cengkareng
Jl. Gotong Royong 1 No.3A
Jl. Gotong Royong 1 Blok M No.3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok M-1 No.3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok 3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok 3A Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok 3A
G-Land Padalarang Residence Blok C No.1, Jayamekar, Padalarang
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}