#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:qwer)+(asdf)"
Local $sString = "qwerasdf" & @CRLF & _
"qwerqwerasdfskldjf" & @CRLF & _
"qwerqwerqwerasdf"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)