import re
regex = re.compile(r"(?:qwer)+(asdf)", flags=re.MULTILINE)
test_str = ("qwerasdf\n"
"qwerqwerasdfskldjf\n"
"qwerqwerqwerasdf")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)