package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:qwer)+(asdf)`)
var str = `qwerasdf
qwerqwerasdfskldjf
qwerqwerqwerasdf`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}