const regex = new RegExp('(?:qwer)+(asdf)', 'gm')
const str = `qwerasdf
qwerqwerasdfskldjf
qwerqwerqwerasdf`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);