use strict;
my $str = 'qwerasdf
qwerqwerasdfskldjf
qwerqwerqwerasdf';
my $regex = qr/(?:qwer)+(asdf)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";