using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\id\"":(\d{6})\,";
string input = @"{""page"":{""offset"":0,""limit"":10000},""collection"":[{""type"":""Friend_bd"",""id"":269158,""dateFormat"":""MM/dd/YYYY""},{""type"":""Friend_bd"",""id"":269159,""dateFormat"":""MM/dd/YYYY""},{""type"":""Friend_bd"",""id"":269160,""dateFormat"":""MM/dd/YYYY""},{""type"":""Friend_bd"",""id"":269161,""dateFormat"":""MM/dd/YYYY""},{""type"":""Friend_bd"",""id"":269162,""dateFormat"":""MM/dd/YYYY""},{""type"":""Friend_bd"",""id"":269163,""dateFormat"":""MM/dd/YYYY""},{""type"":""Friend_bd"",""id"":269053,""dateFormat"":""MM/dd/YYYY""},{""type"":""Friend_bd"",""id"":269064,""dateFormat"":""MM/dd/YYYY""}]}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}