import Foundation
let pattern = #"\id\":(\d{6})\,"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{"page":{"offset":0,"limit":10000},"collection":[{"type":"Friend_bd","id":269158,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269159,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269160,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269161,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269162,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269163,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269053,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269064,"dateFormat":"MM/dd/YYYY"}]}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)