$re = '/\id\":(\d{6})\,/m';
$str = '{"page":{"offset":0,"limit":10000},"collection":[{"type":"Friend_bd","id":269158,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269159,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269160,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269161,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269162,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269163,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269053,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269064,"dateFormat":"MM/dd/YYYY"}]}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);