const regex = /\id\":(\d{6})\,/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\id\\":(\\d{6})\\,', 'gm')
const str = `{"page":{"offset":0,"limit":10000},"collection":[{"type":"Friend_bd","id":269158,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269159,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269160,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269161,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269162,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269163,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269053,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269064,"dateFormat":"MM/dd/YYYY"}]}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}