use strict;
my $str = '{"page":{"offset":0,"limit":10000},"collection":[{"type":"Friend_bd","id":269158,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269159,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269160,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269161,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269162,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269163,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269053,"dateFormat":"MM/dd/YYYY"},{"type":"Friend_bd","id":269064,"dateFormat":"MM/dd/YYYY"}]}';
my $regex = qr/\id\":(\d{6})\,/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}