package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)kafka.(.+)<type=(.+)-metrics,client-id=(.+),topic=(.+),partition=(.+)`)
var str = `kafka.producer<type=producer-topic-metrics,client-id=clientid,topic={topic},partition={partition}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}