import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "kafka.(.+)<type=(.+)-metrics,client-id=(.+),topic=(.+),partition=(.+)";
final String string = "kafka.producer<type=producer-topic-metrics,client-id=clientid,topic={topic},partition={partition}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}