re = /kafka.(.+)<type=(.+)-metrics,client-id=(.+),topic=(.+),partition=(.+)/m
str = 'kafka.producer<type=producer-topic-metrics,client-id=clientid,topic={topic},partition={partition}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end