$re = '/kafka.(.+)<type=(.+)-metrics,client-id=(.+),topic=(.+),partition=(.+)/m';
$str = 'kafka.producer<type=producer-topic-metrics,client-id=clientid,topic={topic},partition={partition}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);