use strict;
my $str = 'Austria: ac.at
Bangladesh: ac.bd
Belgium: ac.be
China: ac.cn
Cyprus: ac.cy
India: ac.in
';
my $regex = qr/[a-z]{2}\.[a-z]{2}/mp;
my $subst = '$Resolved URL$ LIKE "*\\0/*"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";