// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[a-z]{2}\.[a-z]{2}").unwrap();
let string = "Austria: ac.at
Bangladesh: ac.bd
Belgium: ac.be
China: ac.cn
Cyprus: ac.cy
India: ac.in
";
let substitution = "$Resolved URL$ LIKE \"*\\0/*\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}