using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(from|to|cc|bcc):.*(?:\R(?!(?:(?1)|$)).*)*";
string input = @"From support@test.co.uk Wed Nov 20 15:48:00 2013
Return-Path: <support@test.co.uk>
X-Original-To: mailbox@my.domain.com
Delivered-To: mailbox@my.domain.com
Delivered-To: techinfo@test.co.uk
from: ""Lucy 1"" <support@lucky1.co.uk>,""Lucy 2"" <support@lucky2.co.uk>,
""Lucy 3"" <support@lucky3.co.uk>
to: TestTo <techinfo@test.co.uk>
testestest
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}