re = /^(from|to|cc|bcc):.*(?:\R(?!(?:(?1)|$)).*)*/m
str = 'From support@test.co.uk Wed Nov 20 15:48:00 2013
Return-Path: <support@test.co.uk>
X-Original-To: mailbox@my.domain.com
Delivered-To: mailbox@my.domain.com
Delivered-To: techinfo@test.co.uk
from: "Lucy 1" <support@lucky1.co.uk>,"Lucy 2" <support@lucky2.co.uk>,
"Lucy 3" <support@lucky3.co.uk>
to: TestTo <techinfo@test.co.uk>
testestest
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end