import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(from|to|cc|bcc):.*(?:\\R(?!(?:(?1)|$)).*)*";
final String string = "From support@test.co.uk Wed Nov 20 15:48:00 2013\n"
+ "Return-Path: <support@test.co.uk>\n"
+ "X-Original-To: mailbox@my.domain.com\n"
+ "Delivered-To: mailbox@my.domain.com\n"
+ "Delivered-To: techinfo@test.co.uk\n"
+ "from: \"Lucy 1\" <support@lucky1.co.uk>,\"Lucy 2\" <support@lucky2.co.uk>,\n"
+ "\"Lucy 3\" <support@lucky3.co.uk>\n"
+ "to: TestTo <techinfo@test.co.uk>\n\n\n"
+ "testestest\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}