import re
regex = re.compile(r"^(from|to|cc|bcc):.*(?:\R(?!(?:(?1)|$)).*)*", flags=re.MULTILINE)
test_str = ("From support@test.co.uk Wed Nov 20 15:48:00 2013\n"
"Return-Path: <support@test.co.uk>\n"
"X-Original-To: mailbox@my.domain.com\n"
"Delivered-To: mailbox@my.domain.com\n"
"Delivered-To: techinfo@test.co.uk\n"
"from: \"Lucy 1\" <support@lucky1.co.uk>,\"Lucy 2\" <support@lucky2.co.uk>,\n"
"\"Lucy 3\" <support@lucky3.co.uk>\n"
"to: TestTo <techinfo@test.co.uk>\n\n\n"
"testestest\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")