#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(BUG|bug|Bug) *(?:# *)?\d{5,6}$"
Local $sString = "bug 12345" & @CRLF & _
"bug #12345" & @CRLF & _
"BUG # 12345" & @CRLF & _
"Bug#12345" & @CRLF & _
"bug12345"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")