package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(BUG|bug|Bug) *(?:# *)?\d{5,6}$`)
var str = `bug 12345
bug #12345
BUG # 12345
Bug#12345
bug12345`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}