$re = '/^(BUG|bug|Bug) *(?:# *)?\d{5,6}$/m';
$str = 'bug 12345
bug #12345
BUG # 12345
Bug#12345
bug12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);