const regex = new RegExp('^(BUG|bug|Bug) *(?:# *)?\\d{5,6}$', 'gm')
const str = `bug 12345
bug #12345
BUG # 12345
Bug#12345
bug12345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}