re = /^(BUG|bug|Bug) *(?:# *)?\d{5,6}$/m
str = 'bug 12345
bug #12345
BUG # 12345
Bug#12345
bug12345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end