import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^/(?:scripts/my_app/|(?!scripts/)).*";
final String string = "/scripts/my_app/\n"
+ "/scripts/my_app/xxxx.sh\n"
+ "/scripts/my_app/yyyyy/xxxz.sh\n\n"
+ "/scripts/\n"
+ "/scripts/another_string/xxxx.sh\n\n\n"
+ "/xxxx/yyyy/zzzzz/qqqq.sh\n"
+ "/aaaa/bbbb/ccc.sh";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}