$re = '`^/(?:scripts/my_app/|(?!scripts/)).*`m';
$str = '/scripts/my_app/
/scripts/my_app/xxxx.sh
/scripts/my_app/yyyyy/xxxz.sh
/scripts/
/scripts/another_string/xxxx.sh
/xxxx/yyyy/zzzzz/qqqq.sh
/aaaa/bbbb/ccc.sh';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);