import re
regex = re.compile(r"^/(?:scripts/my_app/|(?!scripts/)).*", flags=re.MULTILINE)
test_str = ("/scripts/my_app/\n"
"/scripts/my_app/xxxx.sh\n"
"/scripts/my_app/yyyyy/xxxz.sh\n\n"
"/scripts/\n"
"/scripts/another_string/xxxx.sh\n\n\n"
"/xxxx/yyyy/zzzzz/qqqq.sh\n"
"/aaaa/bbbb/ccc.sh")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")