import Foundation
let pattern = #"^/(?:scripts/my_app/|(?!scripts/)).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/scripts/my_app/
/scripts/my_app/xxxx.sh
/scripts/my_app/yyyyy/xxxz.sh
/scripts/
/scripts/another_string/xxxx.sh
/xxxx/yyyy/zzzzz/qqqq.sh
/aaaa/bbbb/ccc.sh
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)