#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)(ERROR[^\n]*)?(?:.|\n)*?(\d{1,3}%),.*?ETA\s(\d\d.)"
Local $sString = "1ERROR and a description" & @CRLF & _
"Complete: 77%, and ETA 10s"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")