import Foundation
let pattern = #"(?m)(ERROR[^\n]*)?(?:.|\n)*?(\d{1,3}%),.*?ETA\s(\d\d.)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1ERROR and a description
Complete: 77%, and ETA 10s
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}