package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?m)(ERROR[^\n]*)?(?:.|\n)*?(\d{1,3}%),.*?ETA\s(\d\d.)`)
var str = `1ERROR and a description
Complete: 77%, and ETA 10s`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}