$re = '/(?m)(ERROR[^\n]*)?(?:.|\n)*?(\d{1,3}%),.*?ETA\s(\d\d.)/m';
$str = '1ERROR and a description
Complete: 77%, and ETA 10s';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);