use strict;
my $str = '1ERROR and a description
Complete: 77%, and ETA 10s';
my $regex = qr/(?m)(ERROR[^\n]*)?(?:.|\n)*?(\d{1,3}%),.*?ETA\s(\d\d.)/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}