import re
regex = re.compile(r"^(?!.*\/!ut\/).+$", flags=re.MULTILINE)
test_str = ("This is a test. This is a test.\n"
"This is a test /!ut/ This is a test.\n"
"This is a test. This is a test. This is a test.This is a test. This is a \n"
"test.This is a test. This is a /!ut/ test.This is a test. This is a test.This is \n"
"a test. This is a test.\n"
"/!ut/\n"
"test /!ut/\n"
"/!ut/ test")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")