import Foundation
let pattern = #"^(?!.*\/!ut\/).+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This is a test. This is a test.
This is a test /!ut/ This is a test.
This is a test. This is a test. This is a test.This is a test. This is a
test.This is a test. This is a /!ut/ test.This is a test. This is a test.This is
a test. This is a test.
/!ut/
test /!ut/
/!ut/ test
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)